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Acquiring Data 

The University of Guelph Library actively acquires a wide range of geographic and statistical data that can be used 

in a GIS.  You may also wish to display your own data. To access these data you will be required to either download 

it from the GIS or TDR (TriUniversity Data Resources) websites or if a license agreement requires, come into the 

Data Resource Centre.   N.B.: This course does not cover retrieval of statistical data from the TDR website.   

Process:  

1. download to local drive 

2. unzip / process 

3. add to ArcGIS9 - ArcMap 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

Exercise 1: Accessing geospatial data from the Library   

The GIS website provides access to licensed data.  If you are off campus, you will need to authenticate.  In 

this example, we will download Canadian Census data from Stats Canada. 

 

 Navigate to the GIS website from the Library’s homepage:  

 All research resources and collections > Geographic Information Systems 

 Click on “Geospatial data”. 

Click on Canadian Census Geographic. Scroll down to Help/Information – Abbreviations and Codes 

Click on 2001.  Explore this page to find: 

i) Definitions for Census Tract and CMA’s 

ii) Numerical code for the province of Ontario and the Guelph CMA.  

Return to the Geographic Census Data Index page.  

Scroll down to the table of Spatial Files and click on the Cartographic Boundary Files. 
Click on the link to census tracts, ArcInfo and select the file for Ontario, gct_035b02a_e.exe.  

Save to c:\DLItraining 
 

  

   

 Unzip downloaded file to c:\gis\gis\intro9 
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Exercise 2: Unzip/Process and add geospatial data to ArcMap 

Unzip and process 

Navigate to c:\DLI to unzip gct_035b02a_e.exe, select it and double click to unzip it to the same directory.  

The file unzips to an Interchange file format with an .e00 extension.  To import this file into ArcMap you 

need to use a Tool from Arc Toolbox. 

 

Open ArcMap box Start > Programs > ArcGIS > ArcMap.  The program will ask if you want to open the 

program with a new, empty map, as a template or open an existing map project.  Choose a new, empty map. 

Click on the Arc Toolbox icon .  

Expand the Coverage Tools > Conversion > To Coverage tool folders.  

Double click on the Import from Interchange File to open the tool.  Navigate to c:\DLI, click on  

gct_035b02a_e.e00 and click Add.  (Note that the output file name is the same without the .e00 

extension.)  

Click OK. 

 

Add data 

Click the Add Data button  and click on the connect to folder button  to navigate to c:\DLI 

Select gct_035b02a_e  

Click Add.  

 

Now you have a map of all the Census Tracts in Ontario.   
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Data Preparation / Manipulation 

 
Data often comes in geographies larger than what is required by a given project.  For example, we are only 

interested in the CTs for Guelph, but our only choices were to download CTs for all of Ontario or Canada. 

 

Exercise 3: Subset and Create a New Shapefile 

 

Create a Subset 

To reduce the amount of work for ArcGIS to do, you need to select out the Guelph area from the Ontario CT 

theme so that the rest of your analyses are performed only on Guelph data. 

Open the attribute table for gct_035b02a_e.shp (right click on the layer in TOC > Open Attribute Table).  

Examine the contents.  How many records are there?  What fields are there?  Close the table. 

Open the Selection Menu > Select by Attributes. 

Build the expression “CMAUID” = ‘550’   

Click Apply and then Close. 

Zoom to Selected to view the area you have selected. (Selection Menu > Zoom to Selected Features). 

 

Create a new shapefile from selected features 

Right click on gct_035b02a_e.shp in the TOC > Data > Export Data 

Export the selected features using the same coordinate system as the layer’s source data and name 

the output file 550ct.shp. 

Add the new layer to your map when prompted. 

Zoom to layer by right clicking on 550ct > zoom to layer 

Remove gct_035b02a_e.shp (right click > remove) 
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Save your project (File > Save as) to c:\DLI as 550seniors.mxd 

Working with Tables 
Tables are composed of rows/records and fields/columns.  In a theme attribute table, features are stored as 

records (rows) and their attributes are stored as fields (columns).  ArcMap lets you edit the attributes of 

features displayed on your map and the attributes contained in other database tables (for example, a table of 

population statistics) that are not represented geographically on the map. You can edit any of the attribute values 

that appear in a table as well as add and delete records or fields.  You can also use the field calculator to change 

the attribute value of a field for several records at once. 

 

Associating Tables: Joins and Relates 
Features often have many attributes, which are of interest to you.  Good database design suggests that you 

organize your data into multiple tables – each focused on a specific topic – rather than one large table containing all 

your data.  By joining or relating two tables, the tables are ‘connected so that you can use one table to reference 

another.  Two tables can be connected if there is a field in each table, which contains common values in each and 

has unique values in each row of the new additional table.  

There are three basic relationships, which the data in your tables can have to each other.  

One-to-one: Each record in your attribute table relates to only one record in your additional table.  For 

example, house ownership – commonly each owner has only one house and each house has only one owner.  

Tables where the data has a one-to-one relationship are associated using a ‘table join’. Once tables are 

joined, you can query, symbolize and analyze your data based on the joined values.   When joining two tables 

the names of the common fields need not be the same, but the fields need to be of the same data type.   

Joined tables are not permanently connected – the table join is ‘virtual’ and you can remove it whenever you 

wish.  The two tables still exist as separate entities.   
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One-to-many or many-to-one: Each record in your attribute table relates to more than one record 

in your additional table or many records on your attribute table relate to one record in your 

additional table.  For example it is possible that each owner may own more than one house or a house 

may have more than one owner.  Tables with a one-to-many relationship can be associated using a 

‘table relate’.  

Relating tables define a relationship between two tables based on a common field but does not 

append one table to the other.  You relate tables instead of joining them when there is a one-to-many 

or a many-to-many relationship. The tables remain separate and you must open both in order to view 

related data.  You access data in the related table by selecting records in one table and accessing 

the related records in the other table.   

 
Exercise 5: Editing and Joining Tables 

We need to join the statistical table with population data (careseniors.dbf) to the attribute table of 550ct.shp 

(census tracts) in order to create a thematic map showing average income. 

 

Add careseniors550.dbf to your map. 

Open this table and examine the fields.  (Notice that selecting records in your careseniors.dbf table does 

not select corresponding areas on the map.)   

Open the attribute table for the 550ct.shp layer and examine the fields in this table.  (Notice that selecting 

records in this table does select corresponding areas on the map). 

Determine which field is common to both tables and could be used to join the two tables.   

Clear selected features (Selection > clear selected features) 
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Create a new field 

There is no identical field to join the two tables.  But you can use the GEOGRAPHY field in the careseniors.dbf 

table to create a new field that will be in the same format as the 550ct attribute table field – CTUID.  

Open the careseniors.dbf table.   

Click Options > Add Field. 

In the Add Field dialog box enter the following: 

Name: CTUID 

Type: text 

Length: 12 

Click OK. 

Calculate new values 

The examples below represent available geography formats in B2020 for the CTUID.  Our example is working with 
the former: 

Right click on the new CTUID field > calculate values 

Click yes to continue 

Select the string radio button, then using the calculator create the following expression: 

If you are using this format – 550000101  
Left ([GEOGRAPHY],7) & “.” & Right ([GEOGRAPHY],2)   

Click OK 

****If you are using this format: 0001.01 (550000101) 00000   

"550" & Left ( [GEOGRAPHY],7  ) 

Now the CTUID fields in both tables are in the same format ready to join. 
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Join tables 

Right click on the of 550ct.shp layer in the TOC > Joins and Relate > Join.  

In the Join Data dialog box select. 

 What do you want to join to this Layer?:     Join attributes from a table 

 Choose the field in this layer that the join will be based on:  ‘CTUID’  
 Choose the table to join to this layer:     careseniors550 
 Choose the field in the table to base the join on:   ‘CTUID’ 

Click OK and then Yes for the index creation. 

Open the 550ct attribute table.  (An error message may pop-up. This is a bug in the software. Close the 

table.) To solve this problem save the table as a permanent shape file.  

Right click on your census layer in the TOC > Data > Export Data. 

Export the selected features using the same coordinate system as the layer’s source data and name 

the output file 550ctseniors.shp. 

Open  the attribute table to see how careseniors.dbf has been appended to 550ctseniors.shp  

Display your new layer on your map. 

Remove  550ct.shp 

 

Save your project. 
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Classification 

 
To display the information required by your project, you may want to change the way your data are grouped.  

Rather than displaying every elevation as a unique point or every country’s unique population you might want to 

classify your data into groups with similar values and display the groups.  For example, to display elevation you could 

use three groups - low, medium and high.    

 

By default ArcGIS classifies data into five categories using the Natural Breaks method, but you can change the 

number of categories and the method to suit your project.  ArcMap also displays a classification histogram that 

you can use to add or move class breaks and to define the interval, number of classes, and classification method. 

 

To classify your data, you will need to access the Layer Properties dialogue.  This is done by right clicking on the 

layer you wish to manipulate and selecting Properties.  Under the Symbology tab select Quantities and ‘graduated 

colour’.  Under Fields select the field you want to base your classification on and then click on ‘classify’ to choose a 

classification method and number of categories. 
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Exercise 5:  Classification  
 
Classification 

With the care of seniors data attached to the attribute table for Guelph Census Tracts you can create maps that 

show various aspects of care across the neighbourhoods of Guelph.  We will create a thematic map that shows the 

percentage of the population in each census tract that provides 20 hours or more of unpaid care or assistance to 

seniors 

Quantities – Graduated Colour 
Open the 550ctseniors attribute table and examine the fields.  Determine which field you need to display 

20 hours or more of unpaid care provided by the total population. 

Right click on 550ctseniors> Properties > Symbology. 

Change your symbology to show Quantities > Graduated Color. In the fields box choose: 

Value: F20_hours_ 

Normalization: <percent of total> 

Click OK. 

Note: you can experiment with the type of classification method and number of classes. 
 
Save your project. 

Note: 

Refers to the number of hours persons spent providing unpaid care or assistance to seniors of one's own 

household, to other senior family members outside the household, and to friends or neighbours in the week 

(Sunday to Saturday) prior to Census Day (May 15, 2001). Unpaid care or assistance to seniors does not include 

volunteer work for a non-profit organization, religious organization, charity or community group, or work without 

pay in the operation of a family farm, business or professional practice. 
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Exercise 5:  Symbolization 
 

Symbolization 

ArcGIS adds data to your map using single symbol and random colour symbolization that often needs to be 

changed in order to enhance the communication of your map.  Changing the colour, boldness and texture of 

symbols is important in map design.   

 

To illustrate this feature, we will change the symbology of 550grn from single symbol (one colour) to categories 
of unique values to show different classes of roads. 

Add 550grn_clip.shp 

Open the attribute table and examine the fields.  Which field best describes levels of roads? 

Right click on 550grn_clip > Properties > Symbology. 

Change your symbology to display Categories > Unique Values   
Select Class as the field 

Click Add All Values  

Double click on each symbol to change the colour something meaningful 

Uncheck all other values 

Click OK. 

Your roads now display CON (connector roads – no addressing), HI (highways), ST (streets). 

 

Save your project. 
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Making Selections 
 

In order to explore your data or to make a map that highlights the information you want you will need to be able to 

select specific data and locations that interest you.  There are many ways to select attributes and locations. 

 

Before you select data in ArcMap you need to set the selectable layers. This will allow you to pick the layers you 

want without selecting unwanted layers that are under or adjacent to your target.  To set the selectable layers go 

to the Selection tab or menu and choose ‘set selectable layers’.  Ensure that there are only checked boxes next to 

the layers you intend to select from. 

 

Any records that you select will be highlighted, both in the table and in the map.  You can move between the table 

and the map to view your selected features.  Both the map and the table have functions to allow you to zoom into 

the selected features. 

 

Once you have selected features, you can create a new (temporary) layer or export selected features to a new 

feature class or shapefile which can be displayed in your project or saved to display in another project. 
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Exercise 7:  Making Selections 
 
Select using Select Tool:  

Use the Select Tool  to click on one census tract or drag a box around more than one.  Open the 

Attribute table (right click on 550ctseniors and select Open Attribute Table) and click the ‘selected’ toggle 

to see only the selected records.   

 

Select by Attribute: Where are all of the streets that are “courts”? 
From the Selection menu choose ‘Select by attributes’.   

In the 550grn_clip layer ‘create a new selection’.  Build the following expression: 

"TYPE" = ‘CRT' 

Open the 550grn_clip attribute table.  How many courts are there?  

 

Select by Location:  Show me the roads classified as courts in the most southerly CT that has the highest 
percentage of people providing care to seniors. 
 

Under the Selection tab, make sure that 550ct is the only selectable layer. 

From the Selection Menu > Interactive Selection Mode > Add to Current Selection 

Using the Selection tool , select the southerly CT with the highest percentage of people providing care 

to seniors. 

From the Selection menu, choose the Select by Location.  

Fill in the following statement: 

‘I want to “select from the currently selected features in”  

the “550grn_clip” layer  

that “are contained by”  

features in this layer “550ctseniors”.  

Make sure Use selected features is “checked” ’.   

Either count the courts on the map or open the 550grn_clip attribute table to see how many have been 

selected. 
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Coordinate systems 

A reference system used to measure horizontal and vertical distances on a planimetric (plane) map. A coordinate 

system is usually defined by a map projection (its units and characteristics), a spheroid of reference, and a datum. 

It is used to locate x, y positions of point, line, and area features. 

  

The features on a map reference the actual locations of the objects they represent in the real world. The positions 

of objects on the earth's spherical surface are measured in geographic coordinates. To overcome measurement 

difficulties and work with metrical units, spatial data is often transformed from three-dimensional geographic 

coordinates to two-dimensional projected coordinates. Map projections allow areas on the surface of the Earth (a 

spheroid) to be represented on a map (a flat surface). 

 

If all the data you want to display on your map in ArcMap is stored in the same coordinate system, you can just add 

it to a map and not consider whether the layers will overlay properly; they will. If, however, you have collected data 

from a variety of sources in different but predefined coordinate systems, ArcMap re-projects them for display 

on-the-fly and data will overlay properly. The coordinate system of a data frame will correspond to the coordinate 

system of the first added layer. If coordinate systems are not predefined, you have to assign a coordinate system 

to the layers to achieve their proper overlapping.  

 

A projection is needed for publication purposes and for calculating distances.   

 

Coordinate system information can be stored within an ArcView shapefile as a projection file (.prj) or as a table 

within geodatabase. 
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Exercise 8: Permanent re-projection 

 
You may decide to permanently re-project your data from geographic or another projected co-ordinate system.  

One way of doing this is the following: 

In ArcMap, right click on the Layers Data Frame and select Properties. 

In Select a coordinate system click on Predefined > Projected Coordinate Systems > UTM > NAD 1983 
>NAD 1983 UTM Zone 17N. (Note: the system you choose will depend upon the geographic location and scale 

of your project) 

Click Ok and Yes to confirm the Warning (if so). 

Choose a file (ie: 550grn_clip.shp) in the TOC of ArcMap, right click and chose Data > Export Data… > Use 
The Same Coordinate System as the Data Frame and save the Output shape file (ie: 550grnUTM) in the 

appropriate folder. 

Add exported data file as a layer to the map. You will see that two layers 550grn_clip.shp and 550grnUTM 
will overlap perfectly with each other.  This is because ArcGIS re-projects them for display on-the-fly, but 

the base data is stored in different coordinate systems.  
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Layouts 

Once you have manipulated your data to your satisfaction the final step is to create a layout.  A layout is the 

document that presents your results.  When you think of a finished map, with map elements such as a north arrow, 

a title, and a legend, this is called a Layout in ArcMap.  A layout usually includes a map and can also include tables, 

charts, and map elements such as a legend and a scale.  

 

In ArcMap, you create and arrange map elements on a virtual page called a layout. When you create a layout, by 

default it shows the data frames contained in the Table of Contents. You can control which layers display in the 

data frames on the layout by turning them on and off in the Table of Contents.  

 

All the elements in a layout have properties that can be changed or customized to suit your needs. For example, you 

can change the map title's font and size, you can control which layers are shown in the legend, change a data 

frame's background color, add borders around elements, align layout elements relative to each other, and change 

the map's page size and orientation.  

 

You do not have to create a layout from scratch. You can use the Change Layout button   to choose a template 

to base your layout on.  A template lays out the elements of your Layout for you! Modifying an existing layout can 

save you work and time. 
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You will likely want to create a printed document outlining your results.  As part of this document you should 

include a finished map.  To create a layout, select Layout View  under the View menu.  Now we will 

create a layout together including View, a scale bar, a North Arrow, a Title, Neatlines and a Legend. 

 

From Insert menu, you can add map elements to a layout:  

 

Exercise 10:  Create a Layout 
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Appendix 
 

ArcGIS Scalable Software 

ArcGIS is a comprehensive, integrated, scalable system designed to meet the needs of a wide range of GIS users. 

The three desktop levels of ArcGIS are: 

 ArcView (it is different from ArcView 3.x) 

 ArcEditor  

 ArcInfo  

All three ArcGIS components are built from the same core technology.  

 ArcView includes two applications called ArcCatalog and ArcMap 

each embedded with ArcToolbox’s geoprocessing tools.  Together 

these applications allow you to browse, manage, analyze, edit, and document your data.  

 ArcEditor has all the functionality of ArcView plus powerful tools for editing ArcGIS files.   

 

 ArcInfo provides the most functionality and includes all of the capabilities of ArcEditor and ArcView plus 

additional geoprocessing tools. ArcInfo is the complete GIS data creation, update, query, mapping, and 

analysis system. ArcInfo is composed of ArcInfo Desktop and ArcInfo Workstation. 

 

We will be using ArcInfo 9.1 for this workshop. 
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ArcGIS Applications 
 

Each ArcGIS product includes two applications: ArcMap and ArcCatalog™. ArcMap is the application you work with 

to explore and analyze data and make maps. ArcCatalog is the application you work with to manage data. Users will 

typically have two of these applications open at the same time. Additionally, ArcToolbox™ is an integrated 

application that contains many tools for GIS tasks. You can access ArcToolbox from both ArcMap and ArcCatalog. 

 

ArcMap - ArcMap is used to display and query geographic data on maps and to edit and output data.  When you  

  think of a GIS, with a map that you can manipulate on the screen, that is ArcMap.  

 

ArcCatalog – ArcCatalog is the ArcGIS file management system.  It allows you to browse and manage geographic 

data sources and create and update metadata.  ArcCatalog allows you to copy, move and delete ArcGIS 

files without interfering with the integrity of your ArcGIS data.   

 

ArcToolbox  - ArcToolbox contains tools for performing geographic analysis and data conversion. 

 

 

ArcMap 

ArcMap is the application you use to view and edit geographic data and create professional-quality maps, graphs, 

and reports.  

A map is the fundamental component that you will work with in ArcMap.  Maps help you visualize geographic data by 

showing you where things are and what they look like.   ArcMap makes it easy to design maps for printing, 

embedding in other documents, or publishing electronically.   For some data, other presentation methods are more 
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effective than a map. Graphs and reports can show at a glance the information of interest. ArcMap provides many 

options for creating sophisticated graphs and reports 

Geographic Features Objects in the real world are called features when they are represented on a map.   

ArcGIS Features have a shape, location and symbol that represent some of their characteristics.   In ArcGIS 

there are three kinds of features:  

 Points:  An object that is too small to be shown as an area.  E.g. Stop signs, crime locations. 

 Lines:  An object that has length but is too narrow to depict as an area   Eg. Roads, rivers. 

 Polygons:  An object that has visible extent in both length and width.  Eg. Provinces, parks. 

Attributes   In ArcGIS, features are stored in a database along with the information describing them.  The 

descriptive characteristics of a feature are called attributes.  Attributes are stored in a table.   

Layers  Geographic information is displayed on a map as layers, where each layer represents a particular type 

of feature.  A layer is a collection of thematically similar geographic features (such as rivers, lakes, 

counties, or cities) that share the same geographic extent, coordinate system, and attributes.  In 

ArcMap, the Table of Contents lists all the layers shown on the map.    

The table of contents The table of contents lists all the layers on the map and shows what the features in each 

layer represent. The check box next to each layer indicates whether or not the layer is currently 

drawn on the map. By default, the table of contents is located on the left side of the ArcMap window.  

The order of layers within the table of contents is also important; the layers at the top draw on top 

of those below them. Thus, you'll put the layers that form the background of your map, such as the 

ocean, at the bottom of the table of contents. 

Data Frame Layers in the table of contents can be further organized into data frames. A data frame groups, in a 

separate frame, the layers you want to display together.  
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The ArcMap Work Space 
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ArcCatalog 

Think of ArcCatalog as a window into your database. In ArcCatalog, you can browse, organize, distribute, and 

document your GIS data. ArcCatalog resembles Microsoft Windows Explorer but is designed for viewing 

geographic databases, maps, and metadata.  

To access data on your computer's hard drives or your local network, you click the Connect to Folder button and 

navigate to the data.  

The collection of connections you set up to your geographic data is called the Catalog. The Catalog Tree gives you 

access to all of the Catalog's contents. In the ArcCatalog window shown below, the Catalog Tree is on the left side.  

ArcCatalog Tools 

 

Up One Level - moves up one directory level. 

 
Connect to Folder – creates a direct connection to the folder. 

 

Launch ArcMap – launches ArcMap.  

    

Launch ArcToolbox – launches ArcToolbox.  

 

Search – Search for a file or folder. 

 

What’s This?  - Click on the What’s This button and then on any other tool or button to get a description of 

its use.  
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ArcCatalog Tabs 
 

Inside ArcCatalog there are three tabs, each of which provides a unique way to view the contents of a selected 

item in the Catalog Tree.  

 

The Contents tab shows you a list of the selected item's contents.  

 

The Preview tab lets you see the data (both geographic and tabular) contained in the selected item.  

 

The Metadata tab gives you access to documentation about the selected item.                 

 

 

                      

Contents Tab         Preview Tab      Metadata Tab 

              


