
 

  

 

 
 

 

 

Mapping the Census 

Using Open-Source GIS 

The Canadian Census is among one of the most important datasets used in geospatial applications, 

especially when considering demographic characteristics. Learning how to transform the static data 

of the census tables into maps using census geographies helps us gain a better understanding of the 

datasets. In this tutorial we will join a non-map census table with census geography layers. We will use 

this data to calculate new values and symbolize our geography.  



Mapping the Census – DLI Training 2019 

• • • 

1 

 

 

 

 

 

 

 

Getting Started 

 

What are 

Geographic 

Information Systems 

(GIS)? 

• • • 

 

Introduction 

Downloading QGIS 
Quantum GIS, which is often called QGIS, is an open source GIS desktop 

application. Compared to ArcGIS, QGIS can be installed on various 

operating systems, such as Windows, Mac OS X, Linux (Ubuntu), and Unix, 

while ArcGIS only has Windows version. More importantly, QGIS and all 

associated plugins are free.  

Download QGIS (most recent release) 

QGIS User Guide 

 

GIS Data 
A GIS allows us to associate information (non-geographical data) with 

places (geographical data). In our case we will be joining census tables with 

census geographies, then creating a map to communicate and share our 

findings. 

GIS Systems work with many different types of data. Vector data is stored as 

a series of X, Y coordinate pairs inside the computer’s memory. Vector data 

is used to represent points (e.g., towns), lines (e.g., rivers) and areas (e.g., 

provinces). While raster data are stored as a grid of values. 

 

Keep in mind that you’re always able to create new layers when working in 

a GIS. You can do this by either digitizing a new layer from scratch or by 

conducting analysis on existing layers (e.g., buffered distances around 

existing population to show an approximation of growth). 

Our vector data: Census Tracts (polygon) 

Our main vector layer is the Census Tracts for Ontario.  Census tracts (CTs) 

are small, relatively stable geographic areas that usually have a population 

between 2,500 and 8,000 persons. They are located in census metropolitan 

areas and in census agglomerations that had a core population of 50,000 or 

more in the previous census. 

Our raster data: Satellite Basemap 

There are many satellites circling the earth and the photographs they take 

are an example of raster data that can be viewed in a GIS. One important 

difference between raster and vector data is that if you zoom in too much 

on a raster image, it will start to appear ‘blocky’. In fact these blocks are the 

individual cells of the data grid that makes up the raster image. Depending 

on what basemap you decide to use, it may be a raster or vector-tile layer. 

If you’ve chosen a satellite image, then this is an example of raster data.  

 

 

 

A GIS is a framework for 

gathering, managing, and 

analyzing data. Rooted in the 

science of geography, GIS 

integrates many types of data. 

It analyzes spatial location and 

organizes layers of information 

into visualizations using maps 

and 3D scenes.  

With this unique capability, GIS 

reveals deeper insights into 

data, such as patterns, 

relationships, and situations—

helping users make smarter 

decisions. 

Important Terms 

Attributes are nonspatial 

information about a 

geographic feature in a GIS, 

usually stored in a table and 

linked to features. 

The vector data model is 

made up of points, lines and 

polygons (areas).  

Raster data is made up of 

pixels (or grid cells), with each 

pixel having its own value 

(e.g., elevation, rainfall, 

temperature) representing 

continuous data. 

GIS Dictionnary 

https://qgis.org/en/site/forusers/download.html
https://qgis.org/en/docs/index.html
https://support.esri.com/en/other-resources/gis-dictionary/search/
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Where to get census data? 
 

From Statistics Canada 
Census tables can be found and downloaded from Statistics 

Canada.  From the main Statistics Canada page, select the Data Tab, 

under subject select “Population and demography”, on the results are 

‘tables’ or ‘profiles of a community of region’ are examples of Census 

data that can be downloaded. 

 

From Odesi 
Census data can also be downloaded from the <odesi> data delivery 

system. Odesi is available to Ontario Universities and other subscribers. 

 

From the Census Analyzer 
The CHASS Census Analyser allows subscribers to generate custom 

tables from the Census of Canada (1961-2011) and the National 

Household Survey (2011). The interface enables the selection of 

relevant variables and census geographies, providing access to data 

down to the dissemination area (DA) level. A great user guide has 

been created by Carleton University. 

 

Familiarizing yourself with 

the QGIS Interface 

The QGIS interface is divided into 

areas: 

 

Layers List  

Here you can see all the layers 

available to you. Expanding 

collapsed items (by clicking the 

arrow or plus symbol beside them) 

will provide you with more 

information on the layer’s current 

appearance. Right-clicking on a 

layer will give you a menu with lots 

of extra options. You will be using 

some of them before long, so take a 

look around! 

Toolbars 

Your preferred sets of tools can be 

turned into toolbars for basic 

access. For example, the File toolbar 

allows you to save, load, print, and 

start a new project. You can easily 

customize the interface to see only 

the tools you use most often, adding 

or removing toolbars as necessary 

via the Settings ‣ Toolbars menu. 

Even if they are not visible in a 

toolbar, all of your tools will remain 

accessible via the menus.  

Map canvas 

Where the map is displayed 

Status bar 

Shows you the information about 

the current map. Also allows you to 

adjust the map scale and see the 

cursor’s coordinates on the map 

 

Census Geographies 

Mapping census information requires two data components: the 

statistical data as well as a census boundary file (our spatial file) 

which is used to link the statistics to a specific region. 

Census geographies can be downloaded from Scholars GeoPortal, 

for colleges and universities with access. They can also be 

downloaded directly from Statistics Canada. 

CENSUS TRACTS ARE AMONG THE SMALLEST GEOGRAPHIC 

AREAS, AND HAVE POPULATIONS BETWEEN 2,500 AND 

8,000 PEOPLE. THE TRACTS ALLOW US TO SEE PATTERNS AT 

THE NEIGHBORHOOD LEVEL AND ARE LOCATED WITHIN 

CENSUS METROPOLITAN AREAS.  

http://www.statcan.gc.ca/
http://www.statcan.gc.ca/
http://www.odesi.ca/
http://datacenter.chass.utoronto.ca/census/
https://library.carleton.ca/help/census-canada-downloading-canadian-census-analyser-data
http://geo2.scholarsportal.info/#r/search/_queries@=dissemination%20areas;&fields@=;&sort=relevance&limit=entitled
https://www12.statcan.gc.ca/census-recensement/2011/geo/bound-limit/bound-limit-2016-eng.cfm
https://www12.statcan.gc.ca/census-recensement/2011/ref/dict/geo013-eng.cfm
https://www12.statcan.gc.ca/census-recensement/2011/ref/dict/geo009-eng.cfm
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Adding map layers           
We will be starting with a shapefile of all census tracts in Ontario, along with a tabular dataset 

of population change and population density from the 2016 census.    

 

You can add data to QGIS in a few different ways. By either dragging and dropping the .shp 

extension of the shapefile into the map frame or by using the tool ‘Add Vector Layer.’ To find 

the tool navigate to Layer > Add Layer > Add Vector Layer and specify the location of the 

shapefile you would like to add. In our 

case CensusTracts.shp 

To add the tabular data, navigate to 

Layer > Add Layer > Add Deliminited 

Text Layer. Specify ‘No Geometry’ as 

the Geometry Definition, ensure the 

correct File Format is selected and 

Add the text layer (see image on 

right). 

Ensure the columns imported as the 

correct data type by double-clicking 

CensusData in your Layers pane and 

viewing the ‘Source Fields’.  

If numerical data is imported as text 

data then you won’t be able to symbolize the map based on values.  
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If your data did not 

import correctly, you 

can create a .csvt 

file. To do this, simply 

create a text file 

within your working 

folder with the exact 

same file name as 

your table with the 

extension .csvt. You will specify the following within the text of the .csvt file ("Float", "Float", 

"Float", "Float", "Float", "Float") 

Preparing the data layers 

We’ll be joining the CT_UID field to the 

CTUID field in the shapefile, but not 

before we do bit of formatting. 

In order to edit the numbers in the csv 

layer, we must make a copy. 

Return to the menu, right-click on the 

“CensusData” layer, and select Export > 

“Save Features as”. 

Make sure the file format is “Comma 

Separated Value (CSV)”, and select the 

“Add saved file to map” option. 

Browse to the folder for this tutorial and 

save the file with a name that makes 

sense, think about establishing a file 

naming convention for your data. Scroll 

to the dialogue box’s “Layer Options” 

section, select the “YES” option from the 

drop-down menu to the right of 

“CREATE_CSVT”. The .csvt file is a helper 

file that Qgis needs to properly format 

the numbers. If you created a .csvt file in 

the previous step you won’t need to create one here. 

Take the “default” from the drop-down menu to the right of “GEOMETRY”. Click OK. You should 

now have two data tables. 
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Because we don’t need the original layer anymore, we can remove it from the ‘Layers Panel’ 

by right-clicking and selecting the ‘Remove’ option.  

Double-Check: Navigate to your working folder and verify that the newly created .csvt file 

specified the correct field types for all our data. For example if any of the fields are specified 

as ‘String’ then change the text to either integer or double and save the text file. You can 

check these by opening the .csvt file in notepad, if edits are needed simply re-save the file. 

Open the attribute table for your new csv file by right-clicking the layer and selecting “Open 

Attribute Table”.  

Before joining the two layers, we must reformat the numbers in the census tract identification 

fields for both layers. In order to execute a join in QGIS, or any other database program like 

MySQL or Microsoft Access, the columns must contain similarly formatted data. 

Let’s begin with the new csv layer that we created. Open the attribute table and select the 

“Open field calculator” icon at the top right-hand corner of the table’s menu.  

Name the new field ‘CTUID_NEW’ and specify the output field type as ‘Decimal number (real)’. 

Set the precision to 2, specifying 2 decimal points. Expand the Field and Values option in the 

right-hand menu, and double-click GEOUID so that it appears in the text editor on the left-

hand side. Select ‘OK’ and preview the new field.  
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We must perform the same task with our census tract shapefile. Open the attribute table. 

Repeat the same steps to reformat the CTUID field.  

Now we have two matching census tract identification fields.  

Return to the QGIS’ “Layers Panel” menu and double-click the shapefile layer.  

Select the “Joins” option, and click the green 

“+” sign at the bottom of the menu. The layer 

identified in the “Add vector join” dialogue box 

is the csv file we’re about to join to the 

shapefile. 

All that’s left is to tell QGIS which fields we want 

to join, which will be the new ones we’ve 

created. Select the CTUID_NEW field from the 

drop-down menu. And the CTUID_NEW from our 

shapefile. You should now have the two 

matching fields to be joined. Select “Apply” 

and “OK”. 

Open the attribute table to see the joined 

tables. 

 

Querying and Clipping our Data 
You’ll notice that the shapefile layer we added includes ~5000 features. This is an 

unmanageable number of features to effectively map. To create a more mappable layer, we 

are going to query and select only those polygons that correspond to our focus Census 

Metropolitan Area (CMA). In this case, ‘Hamilton’. Feel free to use another CMA if you’d rather. 

Navigate to the attribute table, by right-clicking the Census Tract layer and selecting ‘Open 

Attribute Table’ then select ‘Select features using an 

expression’ 

 

We are going to build the following expression: "CMANAME" = 'Hamilton' 
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Select Features. You should 

have 191 features selected, 

which will show along the 

header of your attribute 

table. They will also be 

highlighted yellow on your 

map view. We’d now like to 

save these selected features 

as a new layer.  

 

Right-click on the Census Tract shapefile layer and select Export > Save Selected Features As…  

Specify the file type as a ‘Shapefile’ and save the layer to your working folder. Use a 

descriptive name such as ‘Hamilton Census Tracts’. Once saved, the layer should appear on 

your map.  

You may not be able to see your layer at first, you can zoom to your new layer by right-

clicking and selecting ‘Zoom to Layer’.  

The uniform colour might make you think nothing has happened. However, that’s because we 

must symbolize, or create a colour scheme that assigns colours on a grid to specific ranges of 

values. 
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Symbolizing our data 
Right-click on your layer, choose “Properties”, then navigate to the “Symbology” section. 

Just below the “Single symbol” option at the top, click the arrow to obtain the drop-down 

menu. Choose “Graduated” and click the arrow to the right of the rectangular box beside 

“Column” to obtain a drop-down menu. Navigate to the column you would like to symbolize. 

QGIS defaults to five “Classes” or categories, which we can increase or decrease as 

necessary. 

Select the “Classify” tab.  

QGIS defaults to a colour ramp, which you can change by clicking on the colour to the right 

of “Colour ramp”. We can also change the intervals between the numbers so that the census 

tracts with negative growth or smaller population density are within the same category. 

QGIS will only display the columns with numeric values.  

Set your categories and colour ramps up to your liking and when you’re happy with your 

choice, select “Apply”, and then “OK”.  

Let’s add an OpenStreetLayers base map. If you don’t have it, go to the “Plugins” section of 

the menu, select “Manage and Install Plugins…”, and search for “OpenLayers” and “Quick 

Finder”. Click “Install plugin.” 

Now you’ll be able to add a basemap underneath your population layers.  

 

Click on the “OpenStreetMap” layer and drag it to the bottom of the menu so that you’re able 

to see your census tracts.  
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At this point, you’ll have a symbology representing your data as well as a basemap to orient 

yourself. To see the actual data, select the “Identify Features” icon above the map.  

We have one more layer to import which will help understand our population data – 

specifically its link to municipal ward boundaries. These boundaries will help us identify the city 

politicians whose wards contain specific census traits.  

City of Hamilton’s Open Data Site contains the municipal ward boundaries we would like to 

add. They are also in the project data folder.  

Load the shapefile into QGIS. 

We’d now like to adjust the symbology to make the ward boundaries transparent, display the 

ward names, and thicken the boundaries to make them easy to see where the census tracts 

lay. You can adjust the symbology and the labels in the “Properties” of the layer using the 

same process as we used to symbolize the census tracts. 

 

Sharing our data 
Now it’s time to export this creation and display for the world to see. 

Right-click on the new layer, and save it as a “KML” file, (which stands for Keyhole Markup 

Language) file, the format Google uses. 

Log-in to Google Drive in your internet browser, if you don’t have an account feel free to set 

one up.  

We are going to add the KML we exported from 

QGIS as a Fusion Table. 

If you don’t have Fusion Tables, you’ll have to 

download it, by clicking on “Connect more apps”. 

Browse for your KML file, select it and go to the next 

step. 

Select “Finish”. 

Select the “Map of geometry” tab at the top right 

to see the map. 

As was the case in Qgis, it is all one, uniform colour. 

To obtain a similar colour ramp, select the “Change 

feature styles” tab to the left. 

http://open.hamilton.ca/datasets/8b0b1f2bf8bb4e1da3a1bf567b17b77f_7
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Under the “Polygons” section, select the “Gradient” option. 

Click on the “Change info window” tab. 

Select the “Automatic legend”, and save the result. 

We can de-select the columns that we don’t want to see in the pop-up box, or we create 

new, and more meaningful labels by selecting the “Custom” option. I recommend using 

something similar to the following: 

<div class='googft-info-window'> 

<b>Population Change: </b> {PopChange}<br> 

<b>2011 Population: </b> {Pop2011}<br> 

<b>2016 Population: </b> {Pop2016}<br> 

<b>Population Density: </b> {PopDensity} 

</div> 

 

Save, then navigate to “Tools” and select the “Publish” option. Make sure the map is shared 

publicly and your link will be viewable to anybody you share it with! 

 

d

 
 

Example: 

https://fusiontables.googleusercontent.com/embedviz?q=select+col17+from+1NVuif0x7d21b3

guhzDZ17z1kheXMYzZcvM_Hex4O&viz=MAP&h=false&lat=43.27327087300543&lng=-

79.935809&t=1&z=11&l=col17&y=2&tmplt=2&hml=KML 

https://fusiontables.googleusercontent.com/embedviz?q=select+col17+from+1NVuif0x7d21b3guhzDZ17z1kheXMYzZcvM_Hex4O&viz=MAP&h=false&lat=43.27327087300543&lng=-79.935809&t=1&z=11&l=col17&y=2&tmplt=2&hml=KML
https://fusiontables.googleusercontent.com/embedviz?q=select+col17+from+1NVuif0x7d21b3guhzDZ17z1kheXMYzZcvM_Hex4O&viz=MAP&h=false&lat=43.27327087300543&lng=-79.935809&t=1&z=11&l=col17&y=2&tmplt=2&hml=KML
https://fusiontables.googleusercontent.com/embedviz?q=select+col17+from+1NVuif0x7d21b3guhzDZ17z1kheXMYzZcvM_Hex4O&viz=MAP&h=false&lat=43.27327087300543&lng=-79.935809&t=1&z=11&l=col17&y=2&tmplt=2&hml=KML

